apt-getで特定のバージョン・古いバージョンをインストール

ぐぐればすぐ見つかる。

apt-cache showpkg パッケージ名
apt-get install パッケージ名=バージョン

例えば、

apt-get install firefox=29.0.1-1vl6

これをやったら、次には特定のパッケージについては自動更新が邪魔になる。
そういう時は

/etc/apt/preferences

を編集する。

Package: firefox
Pin: version 29.0.1-1vl6
Pin-Priority: 1001

というような感じかな。
synapticも期待通りに動いてくれる。